Бухгалтерия / Говнокод #27064 Ссылка на оригинал

0

  1. 1
  2. 2
  3. 3
  4. 4
  5. 5
  6. 6
  7. 7
  8. 8
  9. 9
  10. 10
  11. 11
  12. 12
  13. 13
  14. 14
  15. 15
  16. 16
  17. 17
  18. 18
  19. 19
  20. 20
  21. 21
  22. 22
  23. 23
  24. 24
  25. 25
  26. 26
  27. 27
  28. 28
  29. 29
  30. 30
  31. 31
  32. 32
  33. 33
  34. 34
  35. 35
  36. 36
  37. 37
  38. 38
  39. 39
  40. 40
  41. 41
  42. 42
  43. 43
  44. 44
  45. 45
  46. 46
  47. 47
  48. 48
Функция РазрешеноМенятьЗаявкуПоПравилу9Утра()    
	
 	_Год    = Год  ( Объект.Дата);
	_Месяц  = Месяц( Объект.Дата);
	_День   = День ( Объект.Дата) + 1;
	
	Если _День = 29 Тогда
		Если _Месяц = 2 Тогда
			
			Если (_Год - 2016)%4 <> 0 Тогда	
				
				_Месяц = 3; _День = 1;
			КонецЕсли;  
		КонецЕсли;
	КонецЕсли;
	
	Если _День = 30 Тогда
		Если (_Месяц = 4) ИЛИ (_Месяц = 6) ИЛИ (_Месяц = 9) ИЛИ (_Месяц = 11) Тогда
			
			_Месяц = _Месяц + 1;
			_День  = 1;
		КонецЕсли;
	КонецЕсли;
	
	Если _День = 31 Тогда
		Если (_Месяц = 1) ИЛИ (_Месяц = 3) ИЛИ (_Месяц = 5) ИЛИ (_Месяц = 7) ИЛИ
			(_Месяц = 8)        Тогда
			
			_Месяц = _Месяц + 1;
			_День  = 1;
		ИначеЕсли _Месяц = 12  Тогда
			
			_Месяц = 1;
			_День  = 1; 
		КонецЕсли;
	КонецЕсли;
	
	_9УтраСледующегоДня = Дата( _Год , _Месяц, _День,9,0,0);
	
	Если ТекущаяДата() < _9УтраСледующегоДня Тогда
		
		Возврат Истина;
	Иначе
		
		Возврат Ложь;
	КонецЕсли;
	  
КонецФункции

По-моему, достойно Вашего внимания ;)

ShilkovNikolay ShilkovNikolay, (Updated )

Комментарии (39, +39)

Змея / Говнокод #27063 Ссылка на оригинал

0

  1. 1
  2. 2
  3. 3
  4. 4
  5. 5
  6. 6
  7. 7
  8. 8
  9. 9
  10. 10
  11. 11
  12. 12
  13. 13
  14. 14
  15. 15
  16. 16
  17. 17
def neuro_anec():
    group_id = '85443458'
    random.seed()
    _vk_session = vk_api.VkApi(token=config.service)
    _vk = _vk_session.get_api()
    max_num = _vk.wall.get(owner_id=-int(group_id), count=0)['count']
    try:
        anec_base = ''
        while len(anec_base.split('\n')) < 1 or anec_base == '':
            num = random.randint(1, max_num)
            anec_base = '\n'.join(
                _vk.wall.get(owner_id=-int(group_id), count=1, offset=num)['items'][0]['text'].split('\n')[:-1])
        num = random.randint(1, max_num)
        anec_booter = _vk.wall.get(owner_id=-int(group_id), count=1, offset=num)['items'][0]['text'].split('\n')[-1]
        return anec_base + '\n' + anec_booter
    except:
        return 'А хуй тебе'

Представляю вашему вниманию: ней(гей)росеть, генерирующая анеки категории Б

lpjakewolfskin lpjakewolfskin, (Updated )

Комментарии (30, +30)

Куча говна / Говнокод #27062 Ссылка на оригинал

0

  1. 1
  2. 2
  3. 3
  4. 4
  5. 5
  6. 6
  7. 7
  8. 8
  9. 9
  10. 10
  11. 11
  12. 12
  13. 13
  14. 14
  15. 15
  16. 16
  17. 17
  18. 18
  19. 19
  20. 20
  21. 21
  22. 22
  23. 23
  24. 24
  25. 25
  26. 26
  27. 27
  28. 28
  29. 29
  30. 30
  31. 31
  32. 32
  33. 33
  34. 34
  35. 35
  36. 36
  37. 37
  38. 38
  39. 39
  40. 40
  41. 41
  42. 42
  43. 43
  44. 44
  45. 45
  46. 46
  47. 47
  48. 48
  49. 49
  50. 50
  51. 51
  52. 52
  53. 53
  54. 54
  55. 55
  56. 56
include std/socket.e as s
include std/error.e as err

constant PORT = 5050
constant BACKLOG = 5

procedure die(object result, sequence action) 
	printf(2, "Error %d in %s", {result, action})
	err:crash(action)
end procedure

procedure ensure_zero(integer result, sequence action)
	if result != 0 then
		die(result, action)
	end if 
end procedure

function ensure_seq(object result, sequence action)
	if atom(result) then
		die(result, action)
	end if
	return result
end function

enum SOCKET, READ, WRITE, ERROR
constant PHRASE = "Hello from Euphoria\n"

procedure client_proc(sequence socket)
while 1 do
		for i = 1 to length(PHRASE) do
			sequence result = s:select({}, socket, {}, 0, 100)
			sequence result_s = result[1]
			if result_s[WRITE] = 1 then
				s:send(socket, {PHRASE[i]}, 0)
			end if 
			task_yield()
		end for
end while
end procedure

constant client_proc_id = routine_id("client_proc")

sequence server = ensure_seq(s:create(s:AF_INET, s:SOCK_STREAM, 0), "create")
ensure_zero(s:bind(server, "127.0.0.1", PORT), "bind")
ensure_zero(s:listen(server, BACKLOG), "listen")

while 1 do
	sequence listen_result = s:select(server, {}, {}, 0, 100)
	if listen_result[1][READ] = 1 then
		sequence client = ensure_seq(s:accept(server), "accept")
		printf(1, "Here comes %s\n", {client[2]})
		atom task = task_create(client_proc_id, {client[1]})
		task_schedule(task, {0.5, 0.5})
	end if
	task_yield()
end while

MAKAKA MAKAKA, (Updated )

Комментарии (36, +36)

Куча говна / Говнокод #27061 Ссылка на оригинал

0

  1. 1
IT Оффтоп #68

#40: https://govnokod.ru/26568 https://govnokod.xyz/_26568
#41: https://govnokod.ru/26589 https://govnokod.xyz/_26589
#42: https://govnokod.ru/26600 https://govnokod.xyz/_26600
#43: https://govnokod.ru/26604 https://govnokod.xyz/_26604
#44: https://govnokod.ru/26627 https://govnokod.xyz/_26627
#45: https://govnokod.ru/26635 https://govnokod.xyz/_26635
#46: (vanished) https://govnokod.xyz/_26646
#46: (vanished) https://govnokod.xyz/_26654
#47: https://govnokod.ru/26671 https://govnokod.xyz/_26671
#48: https://govnokod.ru/26707 https://govnokod.xyz/_26707
#49: https://govnokod.ru/26750 https://govnokod.xyz/_26750
#49: https://govnokod.ru/26776 https://govnokod.xyz/_26776
#50: https://govnokod.ru/26804 https://govnokod.xyz/_26804
#51: https://govnokod.ru/26809 https://govnokod.xyz/_26809
#52: https://govnokod.ru/26817 https://govnokod.xyz/_26817
#53: https://govnokod.ru/26833 https://govnokod.xyz/_26833
#54: https://govnokod.ru/26840 https://govnokod.xyz/_26840
#55: https://govnokod.ru/26844 https://govnokod.xyz/_26844
#56: https://govnokod.ru/26862 https://govnokod.xyz/_26862
#57: https://govnokod.ru/26890 https://govnokod.xyz/_26890
#58: https://govnokod.ru/26916 https://govnokod.xyz/_26916
#59: https://govnokod.ru/26934 https://govnokod.xyz/_26934
#60: https://govnokod.ru/26949 https://govnokod.xyz/_26949
#61: https://govnokod.ru/26980 https://govnokod.xyz/_26980
#62: https://govnokod.ru/26999 https://govnokod.xyz/_26999
#63: https://govnokod.ru/27004 https://govnokod.xyz/_27004
#64: https://govnokod.ru/27020 https://govnokod.xyz/_27020
#65: https://govnokod.ru/27027 https://govnokod.xyz/_27027
#66: https://govnokod.ru/27040 https://govnokod.xyz/_27040
#67: https://govnokod.ru/27049 https://govnokod.xyz/_27049

nepeKamHblu_nemyx nepeKamHblu_nemyx, (Updated )

Комментарии (83, +83)

Змея / Говнокод #27060 Ссылка на оригинал

0

  1. 1
  2. 2
  3. 3
  4. 4
  5. 5
  6. 6
  7. 7
  8. 8
  9. 9
  10. 10
  11. 11
  12. 12
  13. 13
  14. 14
  15. 15
  16. 16
  17. 17
  18. 18
  19. 19
  20. 20
  21. 21
  22. 22
  23. 23
  24. 24
number = input("Введите цифру от 1000, до 20000: >")
if int(number) < 1000 or int(number) > 20_000:
    print("Неправильное число")
    exit(0)
 
j = ''  # сделать стринг
 
i = 0  # for
 
maximum = []  # поиск максимального числа
 
count = 0  # ошибка
 
while i < int(number):
    i += 1  # ++
    i_string = str(i)
    j = i_string[::-1]
    if int(i) + int(j) == int(number):
        maximum.append(int(i))
        count += 1  # ошибка
if count == 0:
    print(0)
    exit(0)
print(max(maximum))

Цель кода была в том, чтобы найти максимальный x, по формуле X+F(x) = N, где N число, которое ввели, а F(X) перевёрнутый X
x = 1234 f(x) = 4321

warzon131 warzon131, (Updated )

Комментарии (87, +87)

Си диез / Говнокод #27059 Ссылка на оригинал

0

  1. 1
  2. 2
  3. 3
  4. 4
  5. 5
  6. 6
  7. 7
  8. 8
  9. 9
  10. 10
  11. 11
  12. 12
  13. 13
  14. 14
  15. 15
  16. 16
  17. 17
  18. 18
  19. 19
  20. 20
  21. 21
  22. 22
  23. 23
  24. 24
  25. 25
  26. 26
  27. 27
  28. 28
  29. 29
  30. 30
  31. 31
  32. 32
  33. 33
  34. 34
  35. 35
  36. 36
  37. 37
  38. 38
  39. 39
  40. 40
  41. 41
  42. 42
  43. 43
  44. 44
  45. 45
  46. 46
  47. 47
  48. 48
  49. 49
  50. 50
  51. 51
  52. 52
  53. 53
  54. 54
  55. 55
  56. 56
  57. 57
  58. 58
  59. 59
  60. 60
  61. 61
  62. 62
  63. 63
  64. 64
  65. 65
using System;
using System.Linq;
using System.Text.RegularExpressions;

namespace Filter
{
    class MainClass
    {
        /// <summary>
        /// Filter ver. 1.0
        /// Matching only one word
        /// <created>Aleksandr 23.10.2020</created>
        /// </summary>
        /// <param name="args"></param>
        /// 
        public static void Main(string[] args)
        {
            try
            {
                string str = "ехал грека через редиска че за редиска кек";

                //Настройки=====================================================================
            ////Уберите комментарий строки 20 если хотите ввести свое слово, и уберите строку 21
            ///
            //string str1 = Console.ReadLine();       //<==== decomment
            //==================================================================================

            string str1 = "редиска";

            //если разкомментировали строку 21, то замените слово "тварь" на слвоо которое ввели   //<==== decomment
            Regex regex = new Regex(@"редиска(\w*)");
            MatchCollection matches = regex.Matches(str);
            if (matches.Count > 0)
            {
                foreach (Match match in matches)
                {
                    Console.WriteLine(match.Value);
                }

                var arrS = str.Split(' ').Select(s => s.Trim(',', '?', '.', '!')).ToArray();

                for (var i = 0; i < arrS.Length; i++)
                {
                    if (arrS[i].ToLower() == str1)
                        arrS[i] = "***";
                }
                var newStr = string.Join(" ", arrS);

                Console.WriteLine(newStr);
                Console.ReadLine();
            }
            else
            {
                Console.WriteLine("Совпадений не найдено");
            }
            }
            catch (Exception ex)
            {
                Console.WriteLine($"Исключение: {ex.Message}");
                Console.WriteLine($"Метод: {ex.TargetSite}");
                Console.WriteLine($"Информация об исключении: { ex.InnerException}");
            }
        }
    }
}

AlexStrew AlexStrew, (Updated )

Комментарии (10, +10)

Куча говна / Говнокод #27058 Ссылка на оригинал

0

  1. 1
Питушня #11

#1: https://govnokod.ru/26692 https://govnokod.xyz/_26692
#2: https://govnokod.ru/26891 https://govnokod.xyz/_26891
#3: https://govnokod.ru/26893 https://govnokod.xyz/_26893
#4: https://govnokod.ru/26935 https://govnokod.xyz/_26935
#5: (vanished) https://govnokod.xyz/_26954
#6: (vanished) https://govnokod.xyz/_26956
#7: https://govnokod.ru/26964 https://govnokod.xyz/_26964
#8: https://govnokod.ru/26966 https://govnokod.xyz/_26966
#9: https://govnokod.ru/27017 https://govnokod.xyz/_27017
#10: https://govnokod.ru/27045 https://govnokod.xyz/_27045

nepeKamHblu_nemyx nepeKamHblu_nemyx, (Updated )

Комментарии (114, +114)

Кресты / Говнокод #27057 Ссылка на оригинал

0

  1. 1
  2. 2
  3. 3
  4. 4
  5. 5
  6. 6
  7. 7
  8. 8
  9. 9
  10. 10
  11. 11
  12. 12
  13. 13
  14. 14
  15. 15
  16. 16
  17. 17
  18. 18
  19. 19
  20. 20
  21. 21
  22. 22
  23. 23
  24. 24
  25. 25
  26. 26
  27. 27
// удалить cookie
void delete_cookies() {
    cout << "Set-Cookie: login = ololo; Max-Age=0\n";
    cout << "Set-Cookie: sid = ololo; Max-Age=0\n";
}
// ...
// вывод списка изображений
if(cur_pic>1)
{
    cout << "<a href='http://[DELETED URL]/?"<<cur_pic-1<<"' align='middle'> Previous </a>";
}
if(cur_pic==1)
{
    cout << "<a href='http://[DELETED URL]/?"<< 1 <<"' align='middle' style='color:#00ff00'> 1 </a>";
}
else
{
    cout << "<a href='http://[DELETED URL]/?"<< 1 <<"' align='middle' > 1 </a>";
}
if(cur_pic==2)
{
    cout << "<a href='http://[DELETED URL]/?"<< 2 <<"' align='middle' style='color:#00ff00'> 2 </a>";
}
else
{
    cout << "<a href='http://[DELETED URL]/?"<< 2 <<"' align='middle' > 2 </a>";
}

CGI-приложение на C++ это весело!

groser groser, (Updated )

Комментарии (7, +7)