Бухгалтерия / Говнокод #27144 Ссылка на оригинал

0

  1. 1
  2. 2
  3. 3
  4. 4
  5. 5
  6. 6
  7. 7
  8. 8
  9. 9
  10. 10
  11. 11
  12. 12
  13. 13
  14. 14
  15. 15
  16. 16
  17. 17
  18. 18
  19. 19
  20. 20
  21. 21
  22. 22
  23. 23
  24. 24
  25. 25
  26. 26
  27. 27
  28. 28
  29. 29
  30. 30
  31. 31
  32. 32
  33. 33
  34. 34
  35. 35
&НаСервереБезКонтекста
Функция ПроверкаНаРукожопость1()
	
	ГруппаЮзеровРСЧ = Справочники.ГруппыПользователей.НайтиПоНаименованию("Отдел расчёта сотрудников");
	ЮзерыРСЧ = ГруппаЮзеровРСЧ.Состав.ВыгрузитьКолонку("Пользователь");
	
	ТекущийЮзер = Пользователи.ТекущийПользователь();
	//Если ТекущийЮзер = ЮзерыРСЧ.Найти(ТекущийЮзер) Тогда
	НайденныеЮзеры = ЮзерыРСЧ.Найти(ТекущийЮзер);
	Если (НайденныеЮзеры) <> Неопределено Тогда
		Возврат ИСТИНА;
	Иначе
		Возврат ЛОЖЬ;
	КонецЕсли
	
КонецФункции



&НаКлиенте
Процедура ПриОткрытииПосле(Отказ)
	
	//ПроверкаНаРукожопость(ЭтотОбъект);
	
	//Если РольДоступна("Расчетчик") Тогда
	//	Объект.Дата.Доступность = ЛОЖЬ;
	//КонецЕсли;
	
	Если ПроверкаНаРукожопость1() Тогда
		ЭтотОбъект.Элементы.Дата.Доступность = ЛОЖЬ;
		ЭтотОбъект.Элементы.Номер.Доступность = ЛОЖЬ;
		ЭтотОбъект.Элементы.НомерПриказа.Доступность = ЛОЖЬ;
	КонецЕсли;

КонецПроцедуры

Шобы не рукоблудили шелудивые бухгалтерши

Запостил: Stipa Stipa, (Updated )

Комментарии (3) RSS

  • >//ПроверкаНаРукожопость(ЭтотОбъект)
    >ПроверкаНаРукожопость1()

    какой полиморфизм )))
    Ответить
  • а нельзя
    Если (НайденныеЮзеры) <> Неопределено Тогда
    		Возврат ИСТИНА;
    	Иначе
    		Возврат ЛОЖЬ;
    	КонецЕсли

    заменить на
    возврат (НайденныеЮзеры) <> Неопределено;

    ?
    Ответить

Добавить комментарий

Я, guest, находясь в здравом уме и твердой памяти, торжественно заявляю:

    А не использовать ли нам bbcode?


    8