Бухгалтерия / Говнокод #27948 Ссылка на оригинал

0

  1. 1
  2. 2
  3. 3
  4. 4
  5. 5
  6. 6
  7. 7
  8. 8
  9. 9
  10. 10
  11. 11
  12. 12
  13. 13
  14. 14
  15. 15
  16. 16
  17. 17
  18. 18
  19. 19
  20. 20
  21. 21
  22. 22
  23. 23
  24. 24
  25. 25
  26. 26
  27. 27
  28. 28
Функция ПолучитьПарамтерыОтправкиРеестра()
	Адресат = ПараметрыСеанса.ТекущийПользователь.аОфис.ОфисАрхивации.Ответственный;
	
	Запрос = Новый Запрос;
	Запрос.Текст = "ВЫБРАТЬ
			               |	ТерриторииИПомещения.Ссылка КАК Ссылка
			               |ИЗ
			               |	Справочник.ТерриторииИПомещения КАК ТерриторииИПомещения
			               |ГДЕ
			               |	ТерриторииИПомещения.аОфисПредприятия = &Архив
			               |	И НЕ ТерриторииИПомещения.ПометкаУдаления";
	Запрос.УстановитьПараметр("Архив", Адресат.аОфис.ОфисАрхивации);
	РЗОф = Запрос.Выполнить().Выгрузить();
	Если РЗОф.Количество() = 0 Тогда
		Сообщить("Офис архивации """ + Адресат.аОфис.ОфисАрхивации + """ не прикреплен к территории. Обратитесь в техническую поддержку");
	ИначеЕсли РЗОф.Количество() > 1 Тогда
		Сообщить("Офис архивации """ + Адресат.аОфис.ОфисАрхивации + """ прикреплен к нескольким территориям:");
		Для Каждого СтрТер ИЗ РЗОф Цикл
			Сообщить(СтрТер.Ссылка);
		КонецЦикла;
		Сообщить("Обратитесь в техническую поддержку.");
	Иначе
		ОфисПолучателя = РЗОф[0].Ссылка;	
		ПодразделениеПолучателя = Адресат.Подразделение;		
	КонецЕсли;

	Возврат Новый Структура("Адресат, ОфисПолучателя, ПодразделениеПолучателя", Адресат, ОфисПолучателя, ПодразделениеПолучателя);
КонецФункции

alexey85 alexey85, (Updated )

Комментарии (0)

Змея / Говнокод #27947 Ссылка на оригинал

0

  1. 1
  2. 2
  3. 3
  4. 4
  5. 5
  6. 6
  7. 7
  8. 8
  9. 9
  10. 10
  11. 11
  12. 12
  13. 13
  14. 14
  15. 15
  16. 16
  17. 17
  18. 18
  19. 19
  20. 20
  21. 21
  22. 22
  23. 23
  24. 24
  25. 25
  26. 26
  27. 27
  28. 28
def foo(n):
    f = True
    k = n % 10
    while n > k:
        n //= 10
        if n % 10 != k:
            f = False
            break
    return f

array = [
    [22, 14, 8, 14],
    [22, 13, 70, 95],
    [22, 12, 51, 10], # Для тестирования
    [20, 11, 51, 56],
    [49, 10, 36, 85]
]

f2 = True
for i in range(len(array[0])):
    c = 0
    for j in range(len(array)):
        if foo(array[j][i]):
            c += 1
    if c > 3:
        f2 = False
        break
print("True" if f2 else "False")

Lisya Lisya, (Updated )

Комментарии (38, +38)

ЙажаСценарий / Говнокод #27945 Ссылка на оригинал

0

  1. 1
  2. 2
  3. 3
  4. 4
  5. 5
  6. 6
  7. 7
  8. 8
  9. 9
  10. 10
  11. 11
  12. 12
  13. 13
  14. 14
  15. 15
  16. 16
  17. 17
  18. 18
  19. 19
  20. 20
  21. 21
function testGenRef<T>(v: T) {
    let x = v
    // test that clear() also gets generalized
    function clear() {
	print(x);
        x = null
    }
    clear()
}

function testGenRefOuter() {
    print("testGenRefOuter");
    testGenRef(12)
    testGenRef("fXa" + "baa")
}

function main()
{
    testGenRefOuter()
    print("done.")
}

ну что дорогие мои С/C++ девелоперы.. не ожидали такой подставы... а нука давай свой код на С - С++...

ASD_77 ASD_77, (Updated )

Комментарии (45, +45)

Куча говна / Говнокод #27944 Ссылка на оригинал

0

  1. 1
  2. 2
  3. 3
  4. 4
  5. 5
  6. 6
  7. 7
  8. 8
  9. 9
location ~ ^/(pituh|kurochka) {
    alias "static/pituh.gif";
    default_type image/gif;
}

curl "http://localhost/pituh" - OK
curl "http://localhost/pituh123" - OK
curl "http://localhost/pituh/1/2/3" - OK
curl "http://localhost/pituh/1/2/3/" - INTERNAL SERVER ERROR: static/pituh.gifindex.html" is not a directory

Что это, блядь, за багор и как можно исправить?

3_dar 3_dar, (Updated )

Комментарии (2, +2)

ЙажаСценарий / Говнокод #27943 Ссылка на оригинал

0

  1. 1
  2. 2
  3. 3
  4. 4
  5. 5
  6. 6
  7. 7
  8. 8
  9. 9
  10. 10
function test<T>(t: T)
{
	return t;
}

function main()
{
    print(test(10), test("Hello"));
    print("done.");
}

ура ура.. новая говно-фича подоспела.. а вы думали я тут бездельничаю.. новый год встречаю?

ASD_77 ASD_77, (Updated )

Комментарии (14, +14)

Куча говна / Говнокод #27942 Ссылка на оригинал

0

  1. 1
IT Оффтоп #142

#112: https://govnokod.ru/27648 https://govnokod.xyz/_27648
#113: https://govnokod.ru/27652 https://govnokod.xyz/_27652
#114: https://govnokod.ru/27659 https://govnokod.xyz/_27659
#115: https://govnokod.ru/27665 https://govnokod.xyz/_27665
#116: https://govnokod.ru/27671 https://govnokod.xyz/_27671
#117: https://govnokod.ru/27675 https://govnokod.xyz/_27675
#118: https://govnokod.ru/27685 https://govnokod.xyz/_27685
#119: https://govnokod.ru/27701 https://govnokod.xyz/_27701
#120: https://govnokod.ru/27703 https://govnokod.xyz/_27703
#121: https://govnokod.ru/27710 https://govnokod.xyz/_27710
#122: https://govnokod.ru/27728 https://govnokod.xyz/_27728
#123: https://govnokod.ru/27729 https://govnokod.xyz/_27729
#124: https://govnokod.ru/27730 https://govnokod.xyz/_27730
#125: https://govnokod.ru/27732 https://govnokod.xyz/_27732
#126: https://govnokod.ru/27733 https://govnokod.xyz/_27733
#127: https://govnokod.ru/27737 https://govnokod.xyz/_27737
#128: https://govnokod.ru/27742 https://govnokod.xyz/_27742
#129: https://govnokod.ru/27747 https://govnokod.xyz/_27747
#130: https://govnokod.ru/27755 https://govnokod.xyz/_27755
#131: https://govnokod.ru/27766 https://govnokod.xyz/_27766
#132: https://govnokod.ru/27790 https://govnokod.xyz/_27790
#133: https://govnokod.ru/27828 https://govnokod.xyz/_27828
#134: https://govnokod.ru/27834 https://govnokod.xyz/_27834
#135: https://govnokod.ru/27839 https://govnokod.xyz/_27839
#136: https://govnokod.ru/27845 https://govnokod.xyz/_27845
#137: https://govnokod.ru/27857 https://govnokod.xyz/_27857
#138: https://govnokod.ru/27867 https://govnokod.xyz/_27867
#139: https://govnokod.ru/27887 https://govnokod.xyz/_27887
#140: https://govnokod.ru/27900 https://govnokod.xyz/_27900
#141: https://govnokod.ru/27914 https://govnokod.xyz/_27914

nepeKamHblu_nemyx nepeKamHblu_nemyx, (Updated )

Комментарии (432, +432)

Няшная / Говнокод #27941 Ссылка на оригинал

0

  1. 1
  2. 2
  3. 3
  4. 4
  5. 5
  6. 6
  7. 7
  8. 8
  9. 9
  10. 10
  11. 11
  12. 12
  13. 13
  14. 14
  15. 15
  16. 16
  17. 17
  18. 18
  19. 19
  20. 20
  21. 21
  22. 22
  23. 23
  24. 24
  25. 25
  26. 26
  27. 27
  28. 28
  29. 29
  30. 30
  31. 31
  32. 32
  33. 33
  34. 34
  35. 35
  36. 36
  37. 37
  38. 38
  39. 39
  40. 40
  41. 41
  42. 42
  43. 43
  44. 44
  45. 45
  46. 46
  47. 47
  48. 48
buf = malloc(8 * 1024);

snprintf(buf, 8 * 1024,
     "{\n"
     "\t\"tilejson\": \"2.0.0\",\n"
     "\t\"schema\": \"xyz\",\n"
     "\t\"name\": \"%s\",\n"
     "\t\"description\": \"%s\",\n"
     "\t\"attribution\": \"%s\",\n"
     "\t\"minzoom\": %i,\n"
     "\t\"maxzoom\": %i,\n"
     "\t\"tiles\": [\n",
     tile_config->xmlname, (tile_config->description ? tile_config->description : ""), tile_config->attribution, tile_config->minzoom, tile_config->maxzoom);

for (i = 0; i < tile_config->noHostnames; i++) {
    strncat(buf, "\t\t\"", 8 * 1024 - strlen(buf) - 1);
    strncat(buf, tile_config->hostnames[i], 8 * 1024 - strlen(buf) - 1);
    strncat(buf, tile_config->baseuri, 8 * 1024 - strlen(buf) - 1);
    strncat(buf, "{z}/{x}/{y}.", 8 * 1024 - strlen(buf) - 1);
    strncat(buf, tile_config->fileExtension, 8 * 1024 - strlen(buf) - 1);
    strncat(buf, "\"", 8 * 1024 - strlen(buf) - 1);

    if (i < tile_config->noHostnames - 1) {
        strncat(buf, ",", 8 * 1024 - strlen(buf) - 1);
    }

    strncat(buf, "\n", 8 * 1024 - strlen(buf) - 1);
}

strncat(buf, "\t]\n}\n", 8 * 1024 - strlen(buf) - 1);
len = strlen(buf);

/*
 * Add HTTP headers. Make this file cachable for 1 week
 */
md5 = ap_md5_binary(r->pool, (unsigned char *)buf, len);
apr_table_setn(r->headers_out, "ETag",
           apr_psprintf(r->pool, "\"%s\"", md5));
ap_set_content_type(r, "application/json");
ap_set_content_length(r, len);
apr_table_mergen(t, "Cache-Control",
         apr_psprintf(r->pool, "max-age=%" APR_TIME_T_FMT,
                  maxAge));
timestr = apr_palloc(r->pool, APR_RFC822_DATE_LEN);
apr_rfc822_date(timestr, (apr_time_from_sec(maxAge) + r->request_time));
apr_table_setn(t, "Expires", timestr);
ap_rwrite(buf, len, r);
free(buf);

https://github.com/openstreetmap/mod_tile/blob/master/src/mod_tile.c#L1212

ISO ISO, (Updated )

Комментарии (6, +6)

mysql_real_escape_string / Говнокод #27940 Ссылка на оригинал

0

  1. 1
  2. 2
  3. 3
  4. 4
  5. 5
  6. 6
  7. 7
  8. 8
  9. 9
  10. 10
  11. 11
  12. 12
  13. 13
  14. 14
  15. 15
  16. 16
  17. 17
  18. 18
  19. 19
  20. 20
  21. 21
  22. 22
  23. 23
  24. 24
  25. 25
  26. 26
  27. 27
  28. 28
  29. 29
  30. 30
  31. 31
  32. 32
  33. 33
  34. 34
  35. 35
  36. 36
  37. 37
  38. 38
  39. 39
  40. 40
  41. 41
  42. 42
  43. 43
  44. 44
  45. 45
  46. 46
  47. 47
  48. 48
  49. 49
  50. 50
  51. 51
  52. 52
  53. 53
  54. 54
  55. 55
  56. 56
  57. 57
  58. 58
  59. 59
  60. 60
  61. 61
  62. 62
  63. 63
  64. 64
  65. 65
  66. 66
  67. 67
  68. 68
  69. 69
  70. 70
  71. 71
  72. 72
  73. 73
  74. 74
  75. 75
  76. 76
  77. 77
  78. 78
  79. 79
  80. 80
  81. 81
  82. 82
  83. 83
  84. 84
  85. 85
  86. 86
  87. 87
  88. 88
  89. 89
  90. 90
  91. 91
  92. 92
  93. 93
  94. 94
  95. 95
  96. 96
  97. 97
  98. 98
  99. 99
return QUERY
      with a as 
     (    
         with pr as 
         (
           select p.ss, p.sb, 
             sum(sum_prih)  as sum_prih
           from   material.prihod_by_all_sklads_by_doc_period(dt_ostatki)  p               
           group by 1,2
         ),
          r AS
         (
           select p.ss, p.sb, 
                  sum(p.sum_by_cen)  as sum_rash
           from   material.rashod_by_all_sklads_by_doc_period(dt_ostatki)  p               
           group by 1,2
         ),
         os AS
         (  
            select o.ss, o.sb, 
       --     case  when trim(o.sb)='1150' then 'Запчастини ВКМ,ВПК1,ВПК2,ВПК3,сб. 1150'
      --            when trim(o.sb)='1050' then 'Запчастини ВКМ,ВПК1 сб. 1050' 
   --               when trim(o.sb)='1105' then 'Запчастини ВКМ,ВПК1,ВПК2,ВПК3,сб. 1105'
     --        else  o.name_sklad end as name_skl, 
            sum(o.sum_ost_doc)  as sum_ost_doc--,
           from material.ostatki_by_all_sklads(dt_ostatki) o
           left join material.sklad s  on (s.skladid = o.skladid) 
           group by 1,2
         ),
         topl AS
         (
        select o.ss, o.sb,
              sum(o.ost_sum)   as sum_ost_doc,
              sum(o.vos_sum)   as sum_vos,
              sum(o.prih_sum)   as sum_prih,
              sum(o.rash_sum)   as sum_rash
              from material.ostatki_by_all_toplot(dt_ostatki) o 
              group by 1,2  
         )
        select os.ss, os.sb,
               os.sum_ost_doc,  
               coalesce ( pr.sum_prih,0) as  sum_prih,
                coalesce (r.sum_rash,0) as  sum_rash 
         from os 
         left join pr on (os.ss= pr.ss and os.sb= pr.sb ) 
         left join r on (os.ss= r.ss and os.sb= r.sb )   
        UNION
        select os.ss, os.sb,
               os.sum_ost_doc,  
--                os.sum_vos + os.sum_prih - os.sum_rash  as sum_ost_doc ,
               os.sum_prih,
        --       os.sum_rash
--               case when period_dt$>='2018.08.01'  then COALESCE( r.sum_rash,0) 
--                else  os.sum_vos-os.sum_ost_doc + os.sum_prih end    as sum_rash --os.sum_rash END 
  --             r.sum_rash  
          os.sum_vos-os.sum_ost_doc + os.sum_prih
         
        from topl os left join r on (os.ss= r.ss and os.sb= r.sb )   
/*      
        select o.ss, o.sb,
              sum(o.ost_sum)   as sum_ost_doc,
              sum(o.prih_sum)   as sum_prih,
              sum(o.rash_sum)   as sum_rash
              from material.ostatki_by_all_toplot(dt_ostatki) o  left JOIN r on (r.ss =o.ss and r.sb=o.sb)
              group by 1,2  
  */            
   /*    UNION
       select  ob.ss, ob.sus,
               '112'  as    depart_name,
               '112',
               sum(ob.ost_sum),  
               sum(ob.pr_sum),
               sum(ob.rm_sum)    
       
             from  material.oborot_by_ss_112_by_sklads(period_dt, dt_ostatki)   ob           
             group by 1,2,3,4  */
     ),
     b as
     (
      select bb.ss,bb.sb,bb.sisb_d,bb.sisb_k, bb.sdob, bb.skob from cont.bbz_sald_by_sb(y,m,'112')  bb where bb.sb = '0007'
      UNION
      select bb.ss,bb.sb,bb.sisb_d,bb.sisb_k, bb.sdob, bb.skob from cont.bbz_sald_by_sb(y,m,'153')  bb
      UNION
  --      select bb.ss,bb.sb,bb.sisb_d,bb.sisb_k, bb.sdob, bb.skob from cont.bbz_sald_by_sb(y,m,'152')  bb  
      select bb.ss,bb.sb,bb.sisb_d ,bb.sisb_k, bb.sdob, 0 from cont.bbz_sald_by_sb(y,m,'152')  bb
      UNION
      select bb.ss,bb.sb,bb.sisb_d,bb.sisb_k, bb.sdob, bb.skob from cont.bbz_sald_by_sb(y,m,'201')  bb
      UNION
      select bb.ss,bb.sb,bb.sisb_d,bb.sisb_k, bb.sdob, bb.skob from cont.bbz_sald_by_sb(y,m,'207')  bb 
      UNION
      select bb.ss,bb.sb,bb.sisb_d,bb.sisb_k, bb.sdob, bb.skob from cont.bbz_sald_by_sb(y,m,'209')  bb 
      UNION
      select bb.ss,bb.sb,bb.sisb_d,bb.sisb_k, bb.sdob, bb.skob from cont.bbz_sald_by_sb(y,m,'203')  bb 
      UNION
      select bb.ss,bb.sb,bb.sisb_d,bb.sisb_k, bb.sdob, bb.skob from cont.bbz_sald_by_sb(y,m,'221')  bb 
     -- UNION
     -- select bb.ss,bb.sb,bb.sisb_d,bb.sisb_k, bb.sdob, bb.skob from cont.bbz_sald_by_sb(y,m,'231')  bb 
     -- UNION
     -- select bb.ss,bb.sb,bb.sisb_d,bb.sisb_k, bb.sdob, bb.skob from cont.bbz_sald_by_sb(y,m,'232')  bb

Весь запрос не влез...

Baiumka Baiumka, (Updated )

Комментарии (1, +1)

Школоло / Говнокод #27939 Ссылка на оригинал

0

  1. 1
  2. 2
  3. 3
  4. 4
  5. 5
  6. 6
  7. 7
  8. 8
  9. 9
  10. 10
if  (  (sd<>5)  )    and  //    (Material.ReadOnlySklad =false)      and
          (
              (     Material.TypeSkladId <> 4    )  and
              (
             //    (Material.UserBuh = true )  or (Material.UserAdmin = true)     or
                     (Material.DisunionByOssSb=true )  or  ( credit_operation = true )

              )
            )
           then

Baiumka Baiumka, (Updated )

Комментарии (11, +11)